Login  •  Register


The time is now: Wed Jan 29, 2020 8:30 am

Emaculation wiki  •  Delete all board cookies



Post new topic  Reply to topic Page 1 of 1 [ 8 posts ]
Print view Previous topic  |  Next topic
Author Message
PostPosted: Wed Oct 22, 2008 2:02 am 
Offline
Space Cadet

Joined: Wed Oct 22, 2008 1:41 am
Posts: 2
i am trying to get an old game, spaceship warlock, to play on my emulated mac. this has been quite an undertaking...because every step of the way there have been hang ups...which have eventually been overcome. the literal step by step guide (beginner's guide to emulating a macintosh) was a huge help. (and the version of basilisk 2 i am using was downloaded directly from that page.) but. my issue. i am able to hear sounds only on some programs...and system sounds work fine. but there is no sound from spaceship warlock. i am trying to figure out why this is. i reviewed the readme files that came on the spaceship warlock cd, and it says that for system 7 users and up that 32 bit processing must be turned off (along with setting color to 256...which i can do no problem). but 32 bit processing will not change. when i close the memory control window or even restart with the setting window open with 32 bit off, it will just automatically be back on when i check the setting again. im thinking (and hoping) this may be the issue as to why there is no sound. since the whole game is an audio/visual experience, the sound and graphics are intertwined. but i notice that when it runs, that it seems that at times, the graphics are moving too fast for what would have been corresponding sound.
so close to getting this thing to work!
i am out of ideas. is 32 bit processing a non-changeable setting for the basilisk 2?


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Wed Oct 22, 2008 2:27 am 
Offline
Site Admin
User avatar

Joined: Mon May 20, 2002 4:37 am
Posts: 3748
Location: Uiwang
Well, first off, you should know that the Beginner's Guide is for an OLD version of Basilisk (I wrote that on the top of the page, recently).

You should really try using Basilisk II JIT. Here's a guide for that:

http://emaculation.com/doku.php/basilisk_ii_setup

You can use the same ROM and the same HFV that you have installed Mac OS to. The GUI looks a bit different, but you should be able to figure it out even without reading the new guide.

Try that version and then post again.


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Fri Oct 24, 2008 8:20 am 
Offline
Space Cadet

Joined: Wed Oct 22, 2008 1:41 am
Posts: 2
Yes, the updated page with Basilisk II JIT is what I used. Through the link saying it was very old, try the new updated version. I can't figure this one out. I'm thinking the problem is not being able to turn off 32 bit processing. But I don't understand why graphics work, but not sound. Although, the graphics do seem to be slightly too fast for corresponding sound. I am emulating this on WinXP SP2. Updated the MacOS to 7.5.5. The ROM file is from a quadra 650. Sound works fine with other programs. I doubt its CD corruption. Instructions in the README file says to turn off 32 bit processing for system 7 users and up. But this setting doesn't want to change. I was wondering if perhaps this might be a non-changeable setting for the emulator? Or if not, how would one go about changing this?

Thanks for the reply and link, ClockWise =)

I'm sure this might all sound a bit odd. Or a strange and small goal. But it's something important for me. Perhaps nostalgia and sentimental value. Idk. Anyway. Any help would be much appreciated.


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Fri Oct 24, 2008 3:20 pm 
Offline
Site Admin
User avatar

Joined: Mon May 20, 2002 4:37 am
Posts: 3748
Location: Uiwang
Wait... where are you making this change to the setting??


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Fri Oct 24, 2008 5:24 pm 
Offline
Expert User
User avatar

Joined: Thu Feb 09, 2006 10:24 pm
Posts: 5726
Location: Amsterdam, Netherlands
sardaukar87 refers to a setting in Memory control panel in System 7.5.5. At the time it was intended to provide backward compatiblity with software that could not use 32 bits addressing.
I use BasiliskII MacOX. I never tried to change that setting, but it cannot be changed in BasiliskII MacOSX either.


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Sat Oct 25, 2008 2:44 am 
Offline
Master Emulator
User avatar

Joined: Tue Aug 14, 2007 4:32 pm
Posts: 392
Location: People's Republic of China
BII cannot emulate a dirty-32bit mac at all. so you should try Mini vMac or softMac.


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Sat Oct 25, 2008 2:46 am 
Offline
Site Admin
User avatar

Joined: Mon May 20, 2002 4:37 am
Posts: 3748
Location: Uiwang
I don't see that option in the control panel. Odd.

If a game doesn't work in the newest Basilisk II versions, he could always try good old build 142:

http://home.tampabay.rr.com/osemu/b2_win/mepp.htm


Top
 Profile  
Reply with quote Post a reply  
 Post subject:
PostPosted: Mon Oct 27, 2008 7:32 pm 
Offline
Apple Corer
User avatar

Joined: Thu Oct 16, 2008 10:09 pm
Posts: 203
Location: Canada
Or even better, build 94 can emulate "dirty" roms. It is included in the "Power Pack" Clockwise linked to.


Top
 Profile  
Reply with quote Post a reply  
Display posts from previous:  Sort by  
Post new topic  Reply to topic Page 1 of 1 [ 8 posts ]


Who is online

Users browsing this forum: Google [Bot] and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
 

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group